No components marked as affected
Resolved
This is now resolved.
Investigating
We are continuing to investigate this issue.
Investigating
We are investigating possible delays in pulling results from ChangeHealth. This is specific to Change Health. eLabs Direct by Healthie, Rupa, etc are not impacted.