This is resolved.
Resolved
Identified
We've identified the source of the issue, we are working on a resolution now.
Investigating
We are investigating reports of some users not being able to sign in or create new users in our staging environment