We're confirmed conditional questions not displaying in certain cases was caused by an older version of the UI being used by the browser. Hard refreshing will resolve the issue.
No components marked as affected
Resolved
We're confirmed conditional questions not displaying in certain cases was caused by an older version of the UI being used by the browser. Hard refreshing will resolve the issue.
Identified
We're investigating reports of conditional logic in forms not displaying dependent questions as expected. Some users have found that a hard refresh (Cmd/Ctrl+Shift+R) restores correct behavior. We're working to confirm and will update here.