No components marked as affected
Resolved
This was resolved around 9pm eastern on July 9th.
Investigating
We're seeing some delays in background job processing. This will impact things like generating Scribe notes, tracking notification history, etc. All jobs are being processed and will be completed