Thank you for your patience. All queues are back to normal. The issue appears to have been related to underlying hardware in one of our AWS cluster and was resolved via cycling out all the hardware.
In the process of trying to manually keep queue volumes low and verify different potential solutions, some invalid webhooks were sent out (e.g webhooks for data that does not exist) and which are not able to be actioned on. These did not replace any valid webhooks, and all valid webhooks have been sent.
No components marked as affected
Resolved
Thank you for your patience. All queues are back to normal. The issue appears to have been related to underlying hardware in one of our AWS cluster and was resolved via cycling out all the hardware.
In the process of trying to manually keep queue volumes low and verify different potential solutions, some invalid webhooks were sent out (e.g webhooks for data that does not exist) and which are not able to be actioned on. These did not replace any valid webhooks, and all valid webhooks have been sent.
Monitoring
We have identified the root cause of the processing delays and have released a fix. We are processing background jobs that were delayed and expect them to catch up as the day progresses.
Identified
We continue to see intermittent delays in background jobs.
Resolved
We are seeing intermittent delays with queues today again and are investigating. We'll provide updates as we have them.
Resolved
Job delays have returned to normal.
Investigating
We are investigating some delays in background jobs, including things like transcript processing and webhooks. We will provide updates here and all jobs should eventually process