Resolved
We saw much higher than normal response times between ~2:46-3:00 p.m eastern. This has since been resolved and our team continues to investigate the root cause.
Monitoring
Fix is in place and performance is back to normal. We're monitoring and will close out the incident when we've confirmed a full resolution.
Investigating
We're actively investigating reports of longer than expected load times. You may be unable to login or see white screens when attempting to access our platform.
We'll post another update as soon as we have more to share.