Dosespot Experiencing Slow Loading

Incident Report for Healthie

Resolved

Dosespot resolved their issues last night and this is resolved.
Posted Oct 30, 2025 - 12:07 EDT

Update

Dosespot confirmed an issue related to an Azure outage - https://status.dosespot.com/posts/details/PZWM3CT
Posted Oct 29, 2025 - 13:16 EDT

Investigating

We have received customer reports that the Dosespot prescribing experience is running slower than normal. We have reached out to Dosespot and will provide updates as we learn more.
Posted Oct 29, 2025 - 13:03 EDT
This incident affected: DoseSpot.