Scheduled Maintenance to the AI Scribe and Instant Transcription system

Scheduled for Mar 7, 00:00 - 01:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 06, 2026 - 11:19 EST

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Mar 06, 2026 - 10:39 EST
This scheduled maintenance affects: Healthie (Production).