Spike in response times leading to increased error rate
Incident Report for Healthie
Resolved
We identified this issue as being caused by unexpected memory usage behavior with Postgres, large offsets, and certain sorting options. We have put in immediate term resolutions, and will be moving to cursor-based pagination in the medium term.
Posted Jan 08, 2024 - 16:20 EST
Monitoring
Today, Healthie has seen two periods at approximately ~12:30 and ~2:00pm eastern where we saw large spikes in response times leading to very slow loading and increased timeouts. Each spike lasted approximately ~2 minutes. All services are working normally now. We've identified this as a database issue, and are continuing to investigate the root cause. This did not affect customers with full database separation (https://help.gethealthie.com/article/1170-data-isolation-in-healthie)
Posted Jan 08, 2024 - 14:14 EST