Incorrect Stripe Fees Taken on Recurring and Scheduled Payments
Incident Report for Healthie
Resolved
This incident has been resolved.
Posted Aug 11, 2023 - 12:05 EDT
Investigating
Due to a calculation issue, Recurring and scheduled payments on 8/2, 8/3, and 8/4 had an incorrectly high Stripe fees taken out of the charge. The calculation issue has been corrected, and you will see the difference in fees refunded in a payout initiated today (which should take ~2 business days to reach your connected bank account)
Posted Aug 04, 2023 - 14:15 EDT