Change Healthcare iFrame Appearing Blank
Incident Report for Healthie
Resolved
This issue was resolved by change on 10/6
Posted Oct 09, 2023 - 14:53 EDT
Update
Change has confirmed this is an issue on their end due to a recent release. They plan on releasing an update tomorrow to resolve this.
Posted Oct 04, 2023 - 18:27 EDT
Investigating
Optum (Change Healthcare) Clinical Exchange Lab Orders and Results, a Healthie integration for ordering and resulting e-labs is not currently showign a blank iFrame post log-in for some users. This issue looks to be on Change's end. Optum (Change Healthcare) is investigating and updates will be posted here as they become available. In the meantime, labs can be ordered directly from https://clinician.changehealthcare.com/
Posted Oct 04, 2023 - 12:48 EDT