Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 21, 2023 - 00:00 EDT
Scheduled
Notice for Healthie customers that use Change Healthcare ConnectCenter and/or Claim Management and Eligibility Checking: Please be advised of Change Healthcare quarterly maintenance during the following time period. The maintenance window is not expected to result in noticeable disruption to services.
Posted Oct 18, 2023 - 15:01 EDT
This scheduled maintenance affected: Optum (Change Healthcare).