Possible Delay in ChangeHealth Lab Results

Incident Report for Healthie

Resolved

This is now resolved.
Posted Oct 23, 2025 - 18:17 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:20 EDT

Investigating

We are investigating possible delays in pulling results from ChangeHealth. This is specific to Change Health. eLabs Direct by Healthie, Rupa, etc are not impacted.
Posted Oct 17, 2025 - 13:24 EDT
This incident affected: Healthie (Production).