Twilio issue preventing 2FA code delivery

Incident Report for Healthie

Resolved

This incident is resolved. Texts containing 2FA codes or reminder texts have continued to be received as expected by affected users and we haven't observed any new reports of text message delivery issues.
Posted Jan 15, 2026 - 18:48 EST

Monitoring

Twilio has marked their incident with Verizon as resolved and we're starting to see messages be delivered as normal to affected users.

We're continuing to monitor to ensure the issue that was causing delays in text message receipt is fully addressed. Once we're confident message delivery is back to normal for all accounts, we'll close out this incident.
Posted Jan 15, 2026 - 14:20 EST

Update

Twilio's Engineering team is continuing to work with their carrier partners to resolve the issue causing delivery delays when 2FA codes and reminder texts are sent to US phone numbers under Verizon.

We're still monitoring the situation and will post another update when we have more details.
Posted Jan 14, 2026 - 18:08 EST

Identified

Our SMS provider Twilio is reporting delays in sending to certain US phone carriers including Verizon that could delay the receipt of 2FA and reminder texts.

See additional details on https://status.twilio.com/.

We're monitoring the situation and will provide updates as soon as we know more.
Posted Jan 14, 2026 - 14:06 EST
This incident affected: Healthie (Production).