Slow page loads

Incident Report for Healthie

Resolved

Between ~5:10 and ~5:25 pm eastern, we saw response times on average ~3x slower than normal. This has now been resolved.
Posted Dec 03, 2025 - 17:34 EST

Investigating

We're currently investigating slow page loads across the product. We'll provide updates as we know more.
Posted Dec 03, 2025 - 17:21 EST
This incident affected: Healthie (Production).