Google Calendar sync delays

Incident Report for Healthie

Resolved

Google Calendar sync processing returned to normal as of 3:30 PM ET.

Syncs initially started to be delayed at around 10:30 AM ET, with fixes being deployed at 1:40 PM and 2:45 PM. Queues are now fully caught up and we're marking this incident as resolved.
Posted Feb 23, 2026 - 15:43 EST

Investigating

We're investigating reports of delays in processing Google Calendar sync updates. As soon as we have more details, we'll post another update.
Posted Feb 23, 2026 - 13:17 EST
This incident affected: Healthie (Production).