SFax experiencing delays processing inbound and outbound faxes

Incident Report for Healthie

Resolved

SFax has confirmed they resolved this issue yesterday.
Posted Nov 26, 2024 - 13:12 EST

Update

SFax is continuing to report delays, but we are seeing latency drop in our monitoring (e.g faxes being sent and received in ~15 minutes). We're continuing to monitor
Posted Nov 21, 2024 - 12:28 EST

Monitoring

Our fax provider, SFax, is experiencing delays of up to ~4 hours processing inbound and outbound faxes. This issue appeared to have started Monday and is ongoing. SFax is aware of the issue, and is working to resolve it. All outbound and inbound faxes will be processed, but this issue may lead to seeing faxes stuck in a "Pending" state in Healthie for longer, and to delays with receiving faxes.
Posted Nov 20, 2024 - 09:51 EST
This incident affected: Healthie (Production).