Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2025 - 00:00 EDT
Scheduled
We will be performing improvements to our infrastructure. During this time Healthie features will experience partial or complete unavailability. The anticipated unavailability is a few periods of 10–30 seconds.
Posted Aug 28, 2025 - 17:21 EDT
This scheduled maintenance affected: Healthie (Production).