Scheduling errors

Incident Report for Healthie

Resolved

This issue has been resolved. Patients and providers can now book appointments without errors.
Posted Apr 16, 2026 - 15:23 EDT

Investigating

We are investigating reports of errors when booking appointments.
Posted Apr 16, 2026 - 14:53 EDT
This incident affected: Healthie (Production).