We are currently experiencing delays processing background jobs

Incident Report for Healthie

Resolved

The incident has been resolved and background jobs are being processed normally
Posted May 16, 2026 - 14:18 EDT

Identified

We have identified the issue and are working on a fix.
Posted May 16, 2026 - 13:38 EDT
This incident affected: Healthie (Production).