Twilio issue causing SMS delays

Incident Report for Healthie

Resolved

SMS delivery for all major carriers is back to normal. 2FA and appointment reminder texts are sending again as expected without delay. We're marking this one as resolved.
Posted Nov 28, 2025 - 18:58 EST

Investigating

Our SMS provider, Twilio, is reporting delays sending to US carriers (https://status.twilio.com/) which could potentially delay 2FA and appointment reminder texts (we believe by a few minutes). We are continuing to monitor Twilio's updates as they provide them.
Posted Nov 28, 2025 - 11:56 EST