Response times are back to normal. A Redis server used for caching became non-responsive, leading to much higher response times and timeouts. Our team is investigating and will put mitigating steps in place to ensure this does not happen again. Webhook latency fully returned to normal at ~5:37 pm eastern
Posted Jul 14, 2025 - 16:26 EDT
Monitoring
Our team is seeing response times return back to normal. We are continuing to investigate the root cause.
Posted Jul 14, 2025 - 16:18 EDT
Update
Our team has identified the issue as related to a Redis cluster and continues to investigate
Posted Jul 14, 2025 - 16:16 EDT
Investigating
We are seeing an increase in response times and reports of white screens. Our team is investigating