No components marked as affected
Resolved
Resolved: SMS delivery time for all carriers is back to normal. 2FA and appointment reminder messages are again being sent and delivered without delay.
Investigating
Some 2FA and appointment reminder texts may be delayed by a few minutes. Twilio is investigating an issue affecting certain phone carriers.
We're tracking the incident here: https://status.twilio.com/incidents/lvcmgt3lrdqp. We're monitoring closely and will post updates as we have more details to share.