Interruption with E-Fax Services
Incident Report for Healthie
Resolved
This incident has been resolved. If you received a notification within Healthie that a fax failed to send, please attempt to resend your fax. If the status shows as pending, the fax should send as normal as E-Fax service has been restored.
Posted Aug 11, 2023 - 12:03 EDT
Investigating
We are currently investigating reports of E-Fax messages failing to send. The first report was received at 9:30am EST. Healthie partners with SFAX for E-Fax service. We'll continue to share updates as we work towards restoring faxing services.
Posted Aug 11, 2023 - 11:59 EDT